Members

미국서버에 아무도 관심을 갖지 않는 이유

시패널(cPanel)이 지난 주 ‘시패널 앤 웹호스트 매니저(cPanel & WebHost Manager, WHM)’에서 발견된 3가지 취약점에 대한 패치를 공지했었다. 이 취약점 중 하나는 이중인증 시스템을 우회하도록 해 주기 덕분에 상당히 위험할 수 있을 것이다고 끝낸다.

문제의 ‘시패널 & WHM’은 리눅스용 웹 호스팅 도구들을 모아둔 패키지로, 호스팅 업체나 유저 전원 다체로운 가지 웹 호스팅 및 관리 근무를 자동으로 정리할 수 있게 해준다. 시패널 측의 말을 인용하면 지금 ‘시패널 & WHM’으로 런칭된 도메인은 7천만 개가 넘는다고 한다.

최대로 위험한 문제로 꼽히고 있는 이중인증 우회 취약점은 보안 업체 디지털 디펜스(Digital Defense)에서 발견했으며, 공격자들의 브루트포스 공격을 가능하게 해 준다는 특성을 가지고 있을 것이다. 로그인 크리덴셜을 확보했거나 알고 있는 공격성장하면, 이 취약점을 통해 수분 내에 이중인증 시스템을 뚫어낼 수 있을 것입니다고 완료한다.

하지만 CVSS 점수는 4.1점으로 높은 점수라고 알 수는 없다. “크리덴셜을 미리 느끼고 있는 상태에서 두 번째 인증을 다양한 번 시도해 생각할 수 한다는 게 이 취약점의 핵심”이라는 시패널 측은 “두 번째 인증 요소의 대입 횟수에 제한을 두었다”고 패치 방향을 이야기했었다. 취약한 버전은 11.92.0.3, 11.90.0.17, 11.86.0.32인 것으로 해석됐다.

이 버전들에는 문제가 더 있는 것으로 이해됐다. URL 매개변수 주입이 가능하다는 것이 추가로 발견된 것이다. 이 문제는 다른 인터페이스들의 통합자원식별자(URI)가 야기되는 방법에 기인된다. “URI들을 생성할 때 유저가 제공하는 정보를 URI 신청 매개변수에 함유시키는데, 이 때 URI 인코딩이 https://en.wikipedia.org/wiki/?search=해외서버 아니라 URL 인코딩이 발동됩니다. 즉, 유저가 전망한 것과 다른 결과가 나오도록 유도할 수 있다는 겁니다.”

그 외에도 ‘자가 XSS 취약점’도 발견됐다. 취약점의 정확한 위치는 WHM 트랜스퍼 툴(WHM 일본서버 Transfer Tool) 인터페이스였다. 오차 메시지가 올바르게 인코딩 되지 않아 HTML 코드 주입이 할 수 있는 한 경우가 때때로 나타나는 것이 문제의 핵심이다. 이 취약점의 경우 11.92.0.2 버전과 11.90.0.17 버전에서 발견됐다.

시패널은 이 취약점들의 세부 사항과 패치를 다같이 발표하며 “시패널 내부의 보안 전문가들과 외부에서 독립적으로 활동하는 공무원들이 함께 문제를 인지해 해결했다”며 “악의를 가진 해커 및 사이버 범죄자들이 제일 먼저 이해해 악용하고 있었다고 볼 이유가 전혀 없다”고 주장하기도 하였다.

Views: 2

Comment

You need to be a member of On Feet Nation to add comments!

Join On Feet Nation

© 2022   Created by PH the vintage.   Powered by

Badges  |  Report an Issue  |  Terms of Service